Arrayfire Installation Error.

[Old posts from the commercial version of ArrayFire] Issues and comments for download and installation. Getting up and running.

Moderators: melonakos, pavanky

Arrayfire Installation Error.

Postby phyce » Wed Jun 06, 2012 4:03 pm

Hello, I've been trying to install the free version of arrayfire for python. when i try to install, I get this error:

Traceback (most recent call last):
File "C:\Users\user\Desktop\arrayfire\python\setup.py", line 33, in <module>
CUINC = CUDIR + INC
TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'

It appears that CUDIR = os.getenv('CUDA_PATH') doesn't work fine. What's the dir it should be pointing at? I got the latest version of Nvidia CUDA SDK installed.
the location of the CUDA SDK is:
'C:\Users\user\AppData\Local\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.2'
phyce
 
Posts: 1
Joined: Wed Jun 06, 2012 3:50 pm

Re: Arrayfire Installation Error.

Postby pavanky » Thu Jun 07, 2012 6:00 pm

Hi Phyce,

You need to install the CUDA toolkit. The cuda sdk is different from the toolkit required for ArrayFire.

Right now we dont support cuda 4.2 toolkit, so you will need to download it from the following location
http://developer.nvidia.com/cuda-toolkit-41-archive
Pavan Yalamanchili,
ArrayFire
--
~ If it is not broken, you have not tried hard enough ~
User avatar
pavanky
Site Admin
 
Posts: 1123
Joined: Mon Mar 15, 2010 7:39 pm
Location: Atlanta, GA


Return to [archive-commercial] Download & Installation

cron