Installation does not complete and activation fails

[Old posts from the commercial version of ArrayFire] Issues and comments for download and installation. Getting up and running.

Moderators: melonakos, pavanky

Installation does not complete and activation fails

Postby csg » Tue Oct 08, 2013 10:08 am

Hi,

The ArrayFire installation on my Windows PC does not finish, and running the activate.exe results in the error: "Failed to connect, try checking your internet and firewall settings." My workplace is behind a firewall. According to a previous thread, your license server uses the two ports 27000 and 27901. Is this still correct?

Is this the only reason why the installer doesn't complete? The files are installed, but the installer process keeps running.

Thanks,
Chona
csg
 
Posts: 11
Joined: Mon Oct 07, 2013 7:10 pm

Re: Installation does not complete and activation fails

Postby pavanky » Tue Oct 08, 2013 10:10 am

Hi,

You can always activate using the browser. Are you trying to use the free version or the pro version ?
Pavan Yalamanchili,
ArrayFire
--
~ If it is not broken, you have not tried hard enough ~
User avatar
pavanky
Site Admin
 
Posts: 1123
Joined: Mon Mar 15, 2010 7:39 pm
Location: Atlanta, GA

Re: Installation does not complete and activation fails

Postby csg » Tue Oct 08, 2013 10:25 am

The free version.

Thanks for the reply. I'll try activating online; I didn't know that option existed.
csg
 
Posts: 11
Joined: Mon Oct 07, 2013 7:10 pm

Re: Installation does not complete and activation fails

Postby melonakos » Tue Oct 08, 2013 10:27 am

Only purchased or trial versions can be activated online. The free version requires the installer to activation through the installer.

Would you mind sharing screen shots of what you are seeing so that we can attempt to diagnose and fix whatever it is?

Thanks much!
John Melonakos (john@arrayfire.com)
User avatar
melonakos
 
Posts: 503
Joined: Tue Jun 10, 2008 9:49 am

Re: Installation does not complete and activation fails

Postby csg » Tue Oct 08, 2013 12:26 pm

Hi John,

ArrayFireActivate.PNG
ArrayFireActivate.PNG (22.24 KiB) Viewed 35989 times

I enclosed a screenshot of the error message.

Thanks,
Chona
csg
 
Posts: 11
Joined: Mon Oct 07, 2013 7:10 pm

Re: Installation does not complete and activation fails

Postby pavanky » Tue Oct 08, 2013 12:33 pm

Hi,

To get the free license, it would be easiest if you ran activate.exe on a machine that has internet connectivity. This will download the free license and put it in your my documents folder.

You will however need ports 27000 and 27001 open on your machine to get your free version to work.

Alternatively, you can download the trial license from the website and use it. This will allow you to work offline and also give you ArrayFire pro features for 15 days.

After the trial period is over, you can purchase the full version or try to get the free version to work.

--
Pavan
Pavan Yalamanchili,
ArrayFire
--
~ If it is not broken, you have not tried hard enough ~
User avatar
pavanky
Site Admin
 
Posts: 1123
Joined: Mon Mar 15, 2010 7:39 pm
Location: Atlanta, GA

Re: Installation does not complete and activation fails

Postby csg » Tue Oct 08, 2013 1:52 pm

Hi,

I talked with our IT person. Could you give me the IP address or hostname of the license server?

Thanks,
Chona
csg
 
Posts: 11
Joined: Mon Oct 07, 2013 7:10 pm

Re: Installation does not complete and activation fails

Postby pavanky » Tue Oct 08, 2013 1:58 pm

The server name is "server.accelereyes.com"

The ports we need open are 27000, 27001.
Pavan Yalamanchili,
ArrayFire
--
~ If it is not broken, you have not tried hard enough ~
User avatar
pavanky
Site Admin
 
Posts: 1123
Joined: Mon Mar 15, 2010 7:39 pm
Location: Atlanta, GA

Re: Installation does not complete and activation fails

Postby csg » Tue Oct 08, 2013 2:08 pm

Thanks, Pavan and John. I just made the request to our IT person to open up those ports.
csg
 
Posts: 11
Joined: Mon Oct 07, 2013 7:10 pm

Re: Installation does not complete and activation fails

Postby csg » Tue Oct 08, 2013 3:20 pm

Thanks for your help so far. Unfortunately, activate.exe still gives the same error even after punching the holes through the firewall. Can you think of other factors that may be preventing the activation from taking place?

Thanks,
Chona
csg
 
Posts: 11
Joined: Mon Oct 07, 2013 7:10 pm

Re: Installation does not complete and activation fails

Postby pavanky » Tue Oct 08, 2013 3:23 pm

Hi Chona,

You will need to connect to accelereyes.com for activate.exe to work. You will need the earlier mentioned ports open for the free version to work in general (even after you have the license).

For convenience sake, can you send your account details to support@accelereyes.com so that we will just email you a free license. Please reference this forum link in that email.

--
Pavan
Pavan Yalamanchili,
ArrayFire
--
~ If it is not broken, you have not tried hard enough ~
User avatar
pavanky
Site Admin
 
Posts: 1123
Joined: Mon Mar 15, 2010 7:39 pm
Location: Atlanta, GA

Re: Installation does not complete and activation fails

Postby csg » Tue Oct 08, 2013 3:40 pm

Thank you very much for your help on this. I just sent an email to support@accelereyes.com, as you requested.

I have one more question, and then I hope this thread can be closed. When I try to fix the installation, the files are copied to C:\Windows by the installer. Is there a way to change this location to C:\Program Files\AccelerEyes\ArrayFire\2.0?
csg
 
Posts: 11
Joined: Mon Oct 07, 2013 7:10 pm

Re: Installation does not complete and activation fails

Postby pavanky » Tue Oct 08, 2013 3:41 pm

Can you try re-installing again ? This time when the activation menu pops up, just close it.
Pavan Yalamanchili,
ArrayFire
--
~ If it is not broken, you have not tried hard enough ~
User avatar
pavanky
Site Admin
 
Posts: 1123
Joined: Mon Mar 15, 2010 7:39 pm
Location: Atlanta, GA

Re: Installation does not complete and activation fails

Postby csg » Tue Oct 08, 2013 4:19 pm

I'm afraid I don't even get to that stage. Instead, I get this:

ArrayFireInstaller.PNG
ArrayFireInstaller.PNG (31.61 KiB) Viewed 35975 times


If I choose Modify, then the files are installed in C:\Windows. Selecting Repair doesn't seem to do anything. Remove doesn't remove the files in C:\Program Files\... either, although it will remove files that were installed in C:\Windows.

Thanks or the help.
csg
 
Posts: 11
Joined: Mon Oct 07, 2013 7:10 pm

Re: Installation does not complete and activation fails

Postby shehzan » Tue Oct 08, 2013 7:29 pm

Hi,

We have been able to reproduce the problem you have put forth.
Can you please check the following:
* Whether the C:/Program Files/AccelerEyes/ArrayFire/2.0/ (installation folder) folder is present and all of its contents look intact.
* Whether environment variable AF_PATH exists and points to the correct folder.

If both of these are present, then ArrayFire remains installed on your system.
I would suggest that you go ahead with online activation so that you can use ArrayFire.

We deeply regret the inconvenience and are working to fix this problem.
If you need any further help, please let us know.

---
Shehzan
Developer
AccelerEyes
----
Shehzan
Developer
AccelerEyes
User avatar
shehzan
 
Posts: 121
Joined: Tue Feb 12, 2013 7:20 pm

Re: Installation does not complete and activation fails

Postby csg » Wed Oct 09, 2013 9:20 am

Hi Shehzan,

Thanks for looking into this. I did see that the environment variable is defined, so that explains the problem with uninstallation.

I was able to get a license file from AccelerEyes support, and the test examples seem to be working properly. Thank you very much for the prompt attention and help!

Chona
csg
 
Posts: 11
Joined: Mon Oct 07, 2013 7:10 pm


Return to [archive-commercial] Download & Installation