Problem with CUDA 5.0, OptiX 3.0 and Arrayfire 2.9

[Old posts from the commercial version of ArrayFire] Issues and comments for download and installation. Getting up and running.

Moderators: melonakos, pavanky

Problem with CUDA 5.0, OptiX 3.0 and Arrayfire 2.9

Postby steven.galea » Fri Dec 28, 2012 9:45 pm

Hi,

I installed the latest version for all 3 libraries as specified in the title however I encountered a compatibility issue between CUDA 5 and OptiX 3. I opened a ticket with NVIDIA however in the meantime I would like to downgrade to CUDA 4.2 so that I can continue working. The problem is that AF requires CUDA 5 and won't work with CUDA 4.2. Is it possible to have the installation file for AF 1.2 which is compatible with CUDA 4.2 so that I can continue working while NVIDIA fixes the compatibility issue? I'll upgrade to AF 1.9 once CUDA 5 and OptiX 3 are working properly together.

Thanks,

Steven
steven.galea
 
Posts: 3
Joined: Sun Oct 14, 2012 11:08 am

Re: Problem with CUDA 5.0, OptiX 3.0 and Arrayfire 2.9

Postby umar456 » Mon Dec 31, 2012 4:53 pm

Hi Steven,

It sounds like the incompatibility you are having with Optix is due to the CUDA 5 toolkit and not the driver. If this is the case you can install the CUDA 5 driver but link to the CUDA 4.2 toolkit when you build your Optix project and CUDA 5 toolkit when linking to the ArrayFire project.

You can change which toolkit you want to use by setting the CUDA environment variable or when you are linking your program.
e.g. export CUDA=/usr/local/cuda-5.0

Umar
User avatar
umar456
 
Posts: 7
Joined: Fri Nov 16, 2012 12:24 pm


Return to [archive-commercial] Download & Installation

cron