gactivate error message in OS X

[Old posts from the commercial version of ArrayFire] Issues and comments for download and installation. Getting up and running.

Moderators: melonakos, pavanky

gactivate error message in OS X

Postby arthur.scholz » Sun Aug 28, 2011 4:35 pm

I just upgraded to 1.8.1 from 1.7.

When I run gactivate I get an error message even though everything else seems to be running fine.

Code: Select all
>> addpath /usr/local/jacket/engine
>> gactivate
Welcome to Jacket: The GPU Engine for MATLAB!

Verifying Installation ....

   Is Jacket gpu_entry.mex file found? ....  OK
   Is the driver version correct?      ....  OK
   Is jlicense.dat license file found? ....  OK

Testing Jacket license and runtime ....

Jacket v1.8.1 ( Build b6ad379) by AccelerEyes
License Type: Designated Computer (on 64-bit Mac OS X)
Licensed Addons: none
Multi-GPU: Not Available

Detected CUDA-capable GPUs:
CUDA driver 256.00.35f11, CUDA toolkit 4.0
GPU0 GeForce GT 330M, 512 MB, Compute 1.2 (single)
Display Device: GPU0 GeForce GT 330M

GPU Memory Usage: 328 MB free (512 MB total)

CONGRATULATIONS, JACKET IS ACTIVE AND READY TO USE!

****
Note, if you need to upgrade from a trial license to a
purchased license, select the Host ID below of your most
stable network interface. Then paste the Host ID into the
Manage Licenses page (https://www.accelereyes.com/licenses)
and download the license. Finally, place the file here:
<jacket_root>/engine/jlicense.dat

Mex file entry point is missing.  Please check the (case-sensitive)
spelling of mexFunction (for C MEX-files), or the (case-insensitive)
spelling of MEXFUNCTION (for FORTRAN MEX-files).

JACKET FAILED TO ACTIVATE PROPERLY.

??? Invalid MEX-file '/usr/local/jacket/engine/getmac.mexmaci64': .

Error in ==> /usr/local/jacket/engine/gactivate.p>print_hostids at 174


Error in ==> /usr/local/jacket/engine/gactivate.p>gactivate at 109

 
>> ginfo
Jacket v1.8.1 ( Build b6ad379) by AccelerEyes
License Type: Designated Computer (on 64-bit Mac OS X)
Licensed Addons: none
Multi-GPU: Not Available

Detected CUDA-capable GPUs:
CUDA driver 256.00.35f11, CUDA toolkit 4.0
GPU0 GeForce GT 330M, 512 MB, Compute 1.2 (single)
Display Device: GPU0 GeForce GT 330M

GPU Memory Usage: 328 MB free (512 MB total)
>> grand(4)
 
ans =
 
    0.0620    0.0207    0.9992    0.6775
    0.6746    0.1531    0.5136    0.2978
    0.7100    0.2626    0.4325    0.4253
    0.7672    0.6719    0.8567    0.9327
>>
arthur.scholz
 
Posts: 13
Joined: Tue Dec 07, 2010 9:26 pm

Re: gactivate error message in OS X

Postby vishy » Mon Aug 29, 2011 9:01 am

Arthur,

That error was identified and fixed the next day. Could you download the installer that contains the fix from http://www.accelereyes.com/nightly?
Apologies for the hassle.

-Vish
--------------------------------------------------
Vish Venugopalakrishnan
Software Engineer (Q/A)
AccelerEyes LLC
vishy.v@accelereyes.com

--------------------------------------------------
Resources:
Getting Started, FAQ, Tips, Syntax
User avatar
vishy
 
Posts: 411
Joined: Thu Apr 16, 2009 11:46 am


Return to [archive-commercial] Download & Installation